Vauxhall Corsa E Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi guys, new to site!
Had my new corsa for a few months now and really loving how much of an improvement it is over the D, which was a decent car.

Just had a couple of questions to put out there, noticed since I've driven the car there is a faint vibration through the clutch pedal, especially noticeable when changing up and down in lower gears, has anyone else noticed a similar trait? I could be being over critical here, but can't say I remember my D having such a feature..

The other minor issue, is that I noticed my oil level quality displayed 37% after 3000 miles and I accidentally reset the counter.. Is it weird that it has actually gone back to going down from 100% without actually having an oil change? Doesn't seem particularly fool proof to someone who can be quite clumsy with technology such as myself! Should I be concerned my oil level counter is now compketely skewed?

Hope to hear your feedback guys.
 

·
Registered
Joined
·
1,357 Posts
The oil life indicator is just a number - it's your own fault if you reset it early, unfortunately.

It's there to notify you when to change your oil, and when it hits zero, you do need to change it asap ideally - otherwise your engine will suffer for it.

The only way you can get it back in sync, AFAIK, is to do the oil change and reset it.

Also, 36% after 3000 miles is horrific - you're either driving extremely short journeys or you're ragging it - most likely the former though.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thanks for the reply Limey, I should have mentioned that my car was a ex demostration model so I'm guessing thats why the oil quality level was low when I checked it.
 

·
Registered
Joined
·
454 Posts
Did the Garage not service the car before you collected it. If it was a demo car you would have thought they would have changed the oil
 

·
Registered
Joined
·
1,357 Posts
Zippy said:
Thanks for the reply Limey, I should have mentioned that my car was a ex demostration model so I'm guessing thats why the oil quality level was low when I checked it.
Ah, that explains a lot.

As Klemsy said though, they should have serviced it etc before giving it to you.

Might be worth enquiring about it with your dealer.
 

·
Registered
Joined
·
25 Posts
Hi, I have done 4000 miles and my oil had gone down, so I took it back to dealer and they re set it. They advised me that it seemed to be an error at the factory as some corsas have come in with that light appearing earlier than it should and also vans have been having that happen as well.
Another issue
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top