Vauxhall Corsa E Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi I'm new here.
I have a Vauxhall Corsa 1.0i life 3 door. It's 10 years old. It's done 96miles on the clock. Runs on petrol. Manual drive. Brought the car 4 months ago.

I recently took it to a Vauxhall Garage for a new fuel pump relay. Ever since the car over revs when accelerating but doesn't gain much speed. It takes a good few seconds before it gains speeds. I'm on the dual carriageway going just under 30mph sometimes. Cars over taking me.

I've notice that it seems to happen when I change gear, it takes a while to speed up.

I was wondering if anyone has had the same problem. Or maybe there mechanic online who knows roughly the cause of the problem?
I know nothing about cars.

Oh and on the dashboard a symbol came up with a car and a spanner, take it that means my car needs to go in for a service?
 

·
Registered
Joined
·
1,665 Posts
This forum is only for Latest Corsa late 2014 on, but rather than dismiss your question...
If you are saying that if you are driving along and you put your foot down on the gas, and the engine speeds up but the car doesn't, sounds like the clutch needs replacing, or if you are very lucky needs the clutch actuator adjusting (if it's cable operated on those old ones)
I assume you mean 96,000 miles!
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Jarviser said:
This forum is only for Latest Corsa late 2014 on, but rather than dismiss your question...
If you are saying that if you are driving along and you put your foot down on the gas, and the engine speeds up but the car doesn't, sounds like the clutch needs replacing, or if you are very lucky needs the clutch actuator adjusting (if it's cable operated on those old ones)
I assume you mean 96,000 miles!
Oh, I do apologize, I didn't realise. Yes 96.000 miles. Sorry again.
I take it it's going to cost a lot to get it fixed then. :eek:
 

·
Registered
Joined
·
454 Posts
If the cable just needs adjusting it will not cost much but if it is the clutch it will cost around 300. I had the same on a 15 year old polo and after adjusting the cable I found the clutch was gone cost around 300 for parts and labour
 

·
Registered
Joined
·
33 Posts
The first thing I would do is find out why the car/spanner service light is on.
The car may be in limp home mode.
Find someone with a OBDll fault code reader, AA, RAC, local corner garage.

The clutch on 05/55 Corsa's are self adjusting hydraulically actuated
 
1 - 5 of 5 Posts
Top