Vauxhall Corsa E Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
When I turn on my rear windscreen wiper, the blade only cleans the first and last 1/3 of the windscreen but then comes up off of the screen leaving the middle section of the rear windscreen unwiped. I've taken it to a garage and they could not seem to figure out the problem even when removing the mechanism. Would it be a case of having to get an entirely new rear windscreen kit or is there any internal piece that needs to be replaced to fix the problem.

Any input would be appreciated.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
Is the arm pulling it way from the screen because its bent in some way, or perhaps its something as simple as the blade needs replacement?
I have replaced the blade prior and that hasn’t solved the problem. Took it to a garage and they said there is nothing wrong with the arm at all. I’m thinking it’s a problem i’ll have to go to Vauxhall them self about but god knows how much that’d cost.
 

·
Registered
Joined
·
259 Posts
If you pull the arm down so its not on the screen, does it do the full sweep then.

As Valer 2021 indicates is there any pressure in the spring ? is the joint rusty , WD40 spray helps
 

·
Registered
Joined
·
9 Posts
hey mate, I’m just guessing here as I honeslty have no clue but maybe the bolt connecting the actual wiper to the rotator may be loose? The wiper might be obviously lifting away as it’s moving so it might be worth looking at the bolt and seeing if it’s loose at all
 
1 - 9 of 9 Posts
Top