Vauxhall Corsa E Forum banner
1 - 20 of 22 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
My car came up with a warning saying 'service esc' if you leaving it idling for a couple of minutes, car was serviced last week, then mechanic ran diagnostics and told me it was the rocker cover? So paid for that to be replaced and now all same lights have came on, traction control light and engine check light, any ideas?
 

Attachments

·
Registered
Joined
·
339 Posts
You should get your money back from that useless mechanic. If your engine is a 1.2 or 1.4 then it's probably the coil pack and spark plugs that should get replaced. It's a quite common issue, but to be sure you should hook up a scan tool to your car. If the error is related to misfires, then it's for sure coil pack and plugs.
And just skip the non sense typed by Paul.
 

·
Registered
Joined
·
62 Posts
I also had very similar issues, swapped coil pack and spark plugs.... all fixed. Did you get hesitant acceleration too?

BTW all of £60 ish down at Euro Car Parts and took 15 mins to do.
 

·
Registered
Joined
·
2 Posts
I have the exact same problem with my 2016 astra. Its jerking when still. Little loss of power. Engine and esc light come on. After driving go off.
Have been to garage had p0300 code. Misfire cylinder two.
Oil changed, spark plugs and a coil fitted. All seemed ok for half a day. Now all back on again? Its only done 27000. Losing the will... anyone get to bottom of this
 

·
Registered
Joined
·
339 Posts
Daniellem87 said:
I have the exact same problem with my 2016 astra. Its jerking when still. Little loss of power. Engine and esc light come on. After driving go off.
Have been to garage had p0300 code. Misfire cylinder two.
Oil changed, spark plugs and a coil fitted. All seemed ok for half a day. Now all back on again? Its only done 27000. Losing the will... anyone get to bottom of this
Do a compression test. They are prone to get cracked pistons due to LSPI, that's for both the 1.0T and the 1.4T
 

·
Registered
Joined
·
2 Posts
Compression test has already been done with no issues. This sounds like its going to be a expensive job regardless now. If it is the pistons- is that a fix or new engine- how much does that cost?😱
 

·
Registered
Joined
·
1 Posts
Hi guys I believe it happens when the battery drops below a certain voltage. As it always happens to me on cold mornings. I plugged someones snap on diagnostics into the car and it held about 10 different error codes which come on when a battery is low. I cleared the codes and it didnt come on for about 7 months. Until it got cold again.
 

·
Registered
Joined
·
1 Posts
Hi All,

Sounds like I have a similar problem on my 2016 1.4 Ecoflex.
For a few weeks it's been sporadically misfiring when going up hill (even a slight inclination will do it).
Today, when I had a car full it started properly 'choking' going up hill, the malfunction light came on along with the ESC/TC light and on the digital display it showed a spanner saying Service ESC.
I'm due in for a full service and MOT in a fortnight and hoping the coil pack/spark plug replacement will fix it, but is there anything else that you think I should make my mechanic aware of?
It's only done 26k and I've only had it a year so I'll be gutted if it's anything bigger!
Cheers!
 

·
Registered
Joined
·
92 Posts
Chazi1983 said:
but is there anything else that you think I should make my mechanic aware of?
If you can't breathe down their necks while they do the work, then ask for the old/defective replaced parts to be put in your trunk. Keeps them honest.

I've red plenty of stories of work being billed but not actually being done, or parts just dusted off and/or oiled a bit with WD40 and not replaced (but billed in full). Is possible Daniellem87 's recurring issues may be related to this.

For OP's problem, this thread may also be relevant https://www.corsaeforums.co.uk/viewtopic.php?f=11&t=3785&p=28332#p28332
 

·
Registered
Joined
·
1 Posts
Did you manage to get it sorted?
My 16 Astra Ecoflex has come up with service esc, abs and TC light have come on and a loss of power, engine warning light sometimes comes on too. And known common faults? Thanks
 

·
Registered
Joined
·
206 Posts
My D diesel had same issues, the main dealer changed throttle parts, turbo actuator, and various other bits, each time it cam back with all faults gone, drive it hard foot fully down on an incline and all the lights come back on, and loss of power.

Fortunately the dealers were pretty good as it had the 7 year/lifetime warranty... in the end they replaced the ECU and problem solved..

If i had to pay it was thousands the ECU was £900+vat just parts...
 

·
Registered
Joined
·
1 Posts
Really need some help - same problem as most here service esc light and engine management light been coming on and off for a while. Had some new spark plugs and a new coil pack fitted however this hasnt resolved the problem. Any ideas what to do next or what it could possibly be , cars only 3 years old and had been running perfectly before
 

·
Registered
Joined
·
1 Posts
Hi guys my 2017 manual 1.4 petrol has started doing this I'm a mechanic so access to a reader my codes are
U0077- Control Module Communication Chassis Expansion CAN Bus Off (Sympton 00)

U0401 - Invalid Data Received from ECU MODULE (Symton 00)

I'm getting misfiring slow to pull away and traction control light on sometimes feels like it wheel spins

Never heard of this codes before anyone else ?
 

·
Registered
Joined
·
530 Posts
Looking around internet can't find these codes relating to Corsa E

Would suuget you take the car the an auto electrican as there is an eletrical fault someone that needs to be traced
 

·
Registered
Joined
·
3 Posts
Ok. I had exactly the same issue after I checked engine oil and changed brake pads and discs. What had I done??
There was loss of power but idle was great. I changed the coil pack about 2 years ago and thought it can't be that.
Anyway, I found that I hadn't pressed the dipstick all the way in and air was being sucked passed the o-ring. Pushed it home and Voila. Sorted. You will also have the same issue if the oil filler cap is not on tight.
I am aware that coil packs, purge valves etc do show up the same fault but do yourselves a favour and check the obvious first. I felt a right dipstick 🙄🤣.
 

·
Registered
Joined
·
1 Posts
Had the same issue on my corsa 1.4 eco flex mine was due to spark plugs and coil pack, also a common fault is the purge valve which is a cheap fix again, my error code was fuel was too lean but the way my spark plugs were could see why
 

·
Registered
Joined
·
7 Posts
I've also experienced this. Firstly the car with tyre tracks logo came up and 'Service ESC; came up on the display. Went off after a restart, but then came back. Then went again, but the engine management light came up.

All this happened on Tuesday / Wednesday, I put it into an independent dealer on Thursday and he said it was a PCV Valve which 'nine times out of ten, a simple clean will suffice'

I thought that was it, but after a 300-mile round trip, it is back (Service ESC). A restart made it go again, but it is annoying.

A common scenario seems to be it comes on when idling for a long time in traffic. The garage said it was something to do with emissions - could it be something to do with the new petrol that is being forced upon us?

Or looking at another thread - could it be the coil pack?

I do get a 'rattling' noise when I start quickly from a standstill, consistent with the 'Engine Juddering' thread here
 
1 - 20 of 22 Posts
Top