Vauxhall Corsa E Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
94 Posts
Discussion Starter · #1 ·
Hey, I got my limited edition corsa last Tuesday, and well there is a scratch on it and that's going in for repairs hopefully on Tuesday. Also when I put the wiper on, it keeps banging on the windscreen and making funny noises. It does this infrequently, it's only one of the wipers as well. I am not sure if it's a faulty blade, or something is wrong with the mechanism....but the noise it makes is quite worrying! Any help would be lovely, thank you but the rest of the car is perfect! :)
 

·
Registered
Joined
·
342 Posts
Mines the same it bangs around like mad then other times it doesn't do it and I've had the wipers changed and the mechanism checked
 

·
Registered
Joined
·
455 Posts
Blades are temperamental, I've had to wipe mine as they were leaving this weird mark along the screen, if it's banging it's probably pressing to hard against the screen and what I did with mine was lift it, gently bend it in the desired direction for either more application to the screen or to reduce application to the screen (had to bend mine gently closer to the window as it missed a bit) but never had any problems since
 

·
Registered
Joined
·
1,665 Posts
Use plenty of screenwash and try not to get wax on the screen. If you use a carwash ask them not to spray the screen. Its probably not the main cause of the judder but it makes it worse if the blades are a bit twisted.
 

·
Registered
Joined
·
56 Posts
The wiper blade must be 90 degrees to the screen. If it isn't the arm needs to be twisted whichever way to correct the angle.
 

·
Registered
Joined
·
73 Posts
Hi

I had the same issue a few months back. I had 2 sets of blades replaced under warranty then played up again. they replaced the wiper arms which as solved the problem. don't let them fob you off !!!

SilverRaj said:
Hey, I got my limited edition corsa last Tuesday, and well there is a scratch on it and that's going in for repairs hopefully on Tuesday. Also when I put the wiper on, it keeps banging on the windscreen and making funny noises. It does this infrequently, it's only one of the wipers as well. I am not sure if it's a faulty blade, or something is wrong with the mechanism....but the noise it makes is quite worrying! Any help would be lovely, thank you but the rest of the car is perfect! :)
 

·
Registered
Joined
·
73 Posts
Hi

I had the same issue a few months back. I had 2 sets of blades replaced under warranty then played up again. they replaced the wiper arms which as solved the problem. don't let them fob you off !!!
 

·
Registered
Joined
·
152 Posts
I'm having a problem with my wippers too around certain speed there is a rattle and sometimes the right-side wipper doesnt go down all the way as it should stays like 5 cm's above the place it should be in
 

·
Registered
Joined
·
74 Posts
Having the same problem with my wipers not going fully down and making clicking noises when sitting down on the bottom. :eek:
 

·
Registered
Joined
·
152 Posts
skywhite said:
Having the same problem with my wipers not going fully down and making clicking noises when sitting down on the bottom. :eek:
Took mine to the dealer today to solve a pile of issues being that one of them if it's solved ill ask them what was faulty to help you solve your issue
 

·
Registered
Joined
·
94 Posts
Discussion Starter · #12 ·
I took mine to the dealer, they said its normal and after a while it the noise will fade away.....well it's been almost one month and the ticking noise is still there! Their mechanic checked it and said the blades are fine, and so is the mechanism so I am not really sure what the problem is. :(
 

·
Registered
Joined
·
10 Posts
My large wiper was missing two sections of the screen, as if the arm was applying to much pressure to the blade. Causing the blade to lift of the screen, top and bottom, I gently bent the arm but no luck. after couple of weeks mucking around with it, took it to dealers. They just took wiper of a new car and changed it over, which sorted it, hopefully for good.
 

·
Registered
Joined
·
1 Posts
Hello ! :p

might be out of topic ,but maybe time for replacement?as far ,as I ve been told ,wiper blades after some time might become noisy and not work proper as they should..friend of mine who bought set of hybrid HEYNER brand on amazon is fully satisfied with purchase because after 4 months they are still excelent,quiet and do the job.
 

·
Registered
Joined
·
64 Posts
I've had this with my corsa D since the 3rd month of its life or so. It would Complete its wipe cycle perfectly normal, no issues, then when I turn it off, it will be sitting at the bottom of its travel where it normally sits and I swear I can still hear the mechanism trying to go that little bit further like a tiny clunking noise, like trying to fit back in place. Does this after maybe 10-30 seconds only a few times then stops.

I dunno, I might just be hearing things!
 

·
Registered
Joined
·
8 Posts
Hi All,

I have started a new post on this, my New corsa is doing the same with a very irritating clonking noise coming from the Mechanism... Vauxhall Technical say this is normal and a characteristic of the car. I have never had a modern car with such a noisy wiper set up!!!

Any suggestions or help would be great.
 
1 - 16 of 16 Posts
Top