Wind screen wash jets not working?

Faults and Technical chat for the Corsa E
Post Reply
Jezzinski
Posts: 2
Joined: Wed Mar 21, 2018 3:28 am

Wind screen wash jets not working?

Post by Jezzinski » Wed Mar 21, 2018 3:32 am

Hi guys, so recently my windscreen wash jets stopped working (front and back at the same time) ive checked the water/screenwash which is full and also poked into the nozzles to check for blockage. Also when I activate it, it no longer makes the whirring noise its completly silent. Ive been told it could be a dead fuse but wantes to get you guys opinion. Thanks in advance

User avatar
Nickosnose
Posts: 104
Joined: Thu Nov 02, 2017 9:28 pm

Re: Wind screen wash jets not working?

Post by Nickosnose » Wed Mar 21, 2018 7:49 am

Could be the actual pump on the side of the bottle....cheap and easy to do..

TheGeorge
Posts: 91
Joined: Tue Apr 25, 2017 6:26 am

Re: Wind screen wash jets not working?

Post by TheGeorge » Wed Mar 21, 2018 9:56 am

In order of probability:

* Pump Fuse (could have blown in the cold snap, if the windscreen wash froze and somebody attempted to operate it)
* Loose wire coupling
* Corroded coupling
* Faulty switch in the dashboard (this one could be on the expensive side to replace)
* Faulty relay
* Faulty pump

Pump can be rigged to the battery to see if it comes alive, but if you are not handy around electrical/mechanical stuff i'd not risk it.

An easier job is replacing the fuse (location and Amps are in the car's manual, replace only with same size/rating). If replacing the fuse didn't help (or if it blew immediately upon triggering the pump), I'd say to get the car into a service for a diagnostic.
Corsa E - 1.4T
MY 2016

Jezzinski
Posts: 2
Joined: Wed Mar 21, 2018 3:28 am

Re: Wind screen wash jets not working?

Post by Jezzinski » Wed Mar 21, 2018 2:57 pm

Im going to try swapping out the fuse to start with. Do you know what amp it would be?

Susan44
Posts: 393
Joined: Tue Jan 05, 2016 12:33 pm

Re: Wind screen wash jets not working?

Post by Susan44 » Wed Mar 21, 2018 9:17 pm

Manual says "washer system " fuse 24 suggesting that front and back share the same fuse. Does the back washer work?
1.4 Auto SE. Intellilink R3.0 software version 109.0-39112275 :geek:

djingo
Posts: 1
Joined: Tue Mar 02, 2021 12:24 pm

Re: Wind screen wash jets not working?

Post by djingo » Tue Mar 02, 2021 12:33 pm

Hi guys,

Same issue here and same symptoms as the OP:

Front and rear stopped at the same time which I think eliminates the possibility of simultaneous blocking of nozzles.

Pump makes noise when operated but no water comes out. Poking nozzles with a needle didn't change anything.

I've read on Corsa D there's a washer filter/screen where the pump connects to that can get easily clogged. Followed instructions from an online video for a Corsa D, not identical setup but similar, however when I got to the pump, i could only push up a few mm but it wouldn't free itself from where it rests no matter what. Used a flat screwdriver as a lever arm, no success plus it dented the bottle slightly. Even thought of jacking it up using some piece of wood but I am afraid I will break something as it didn't feel it should be pushed more.

Pic of where I am trying to push:

Image

Any ideas please?

Post Reply