Huawei P20 Android Auto

All Corsa E related discussions
Post Reply
warnerr88
Posts: 1
Joined: Mon Jul 23, 2018 10:41 am

Huawei P20 Android Auto

Post by warnerr88 » Mon Jul 23, 2018 10:52 am

I've recently purchased a 17 plate Corsa E and will be looking at changing my phone soon. I currently have an iPhone 7 which works fine with Apple Play but I am thinking of getting a Huawei P20 (not the pro) and wondering does anybody have one and does it work fine with Android Auto?


steedoo
Posts: 12
Joined: Mon Mar 19, 2018 10:45 pm

Re: Huawei P20 Android Auto

Post by steedoo » Tue Jul 24, 2018 10:00 pm

It's probably the quality of the cable that you use to connect the phone to the car that you need to watch rather than the phone itself. It's best to use the cable that comes with the phone and not a pound shop cheapie.
1.4 Automatic SE


User avatar
jaysen
Posts: 73
Joined: Thu May 28, 2015 6:32 am
Location: SUNNY ROCHDALE

Re: Huawei P20 Android Auto

Post by jaysen » Wed Sep 12, 2018 8:31 am

Hi. I have a p20 pro, I have a 67plate vxr and it works perfectly with Android connect, i found that it would only connect using the original USB cable for Google maps, I tried after market one 1st with no joy, did a Google search which solved my issue
Panoramic Tilt & slide sunroof
Bi-xenon headlights


Ants
Posts: 1
Joined: Thu Sep 20, 2018 12:45 am

Re: Huawei P20 Android Auto

Post by Ants » Thu Sep 20, 2018 12:49 am

I have a p20 lite and it will not work with my 16 plate Corsa at all, tried using different cables and even tried it on my friends corsa.


paul04
Posts: 21
Joined: Thu Mar 22, 2018 6:41 pm

Re: Huawei P20 Android Auto

Post by paul04 » Thu Sep 20, 2018 2:51 am

[quote=Ants post_id=27794 time=1537400943 user_id=2817]
I have a p20 lite and it will not work with my 16 plate Corsa at all, tried using different cables and even tried it on my friends corsa.
[/quote]

Have you downloaded and installed the android auto app on your phone? Also have you gone into the settings on the radio and enabled android auto?


markyap73
Posts: 2
Joined: Fri Sep 28, 2018 9:12 pm

Re: Huawei P20 Android Auto

Post by markyap73 » Fri Sep 28, 2018 9:31 pm

Hi all,

I cannot connect my P20 Lite via USB on my 16 plate. Bluetooth is fine and I've got no problems on that. When I connect using the USB cable that came with the phone (with Android Auto running), the head unit doesn't even pick up a USB device (with Bluetooth off). I have tried different cables, adaptors and even on a different Corsa.... no luck. I've checked the settings on the head unit and all is good. Even tried my wife's Sony ZX and that linked with no problems, Google maps popped up on the display.

I've raised a help ticket with Vauxhall.... fingers crossed that they have a fix for this.


bearded_ed
Posts: 40
Joined: Mon Feb 12, 2018 2:50 pm

Re: Huawei P20 Android Auto

Post by bearded_ed » Sat Sep 29, 2018 6:36 pm

markyap73 wrote:
Fri Sep 28, 2018 9:31 pm
Hi all,

I cannot connect my P20 Lite via USB on my 16 plate. Bluetooth is fine and I've got no problems on that. When I connect using the USB cable that came with the phone (with Android Auto running), the head unit doesn't even pick up a USB device (with Bluetooth off). I have tried different cables, adaptors and even on a different Corsa.... no luck. I've checked the settings on the head unit and all is good. Even tried my wife's Sony ZX and that linked with no problems, Google maps popped up on the display.

I've raised a help ticket with Vauxhall.... fingers crossed that they have a fix for this.
So whilst I only have a '15 plate and therefore no Android Auto. But with my Huawei Mate 10 Pro I also get an error message or nothing from the system when using USB. Maybe its just Huawei :(
2015 5DR Corsa 1.4 (90) SE + All the extras except R4.0 :(


User avatar
Cabooshy
Posts: 12
Joined: Mon Jul 30, 2018 3:59 pm
Location: Fleet, GB
Contact:

Re: Huawei P20 Android Auto

Post by Cabooshy » Mon Oct 01, 2018 2:32 pm

bearded_ed wrote:
Sat Sep 29, 2018 6:36 pm
So whilst I only have a '15 plate and therefore no Android Auto. But with my Huawei Mate 10 Pro I also get an error message or nothing from the system when using USB. Maybe its just Huawei :(
On the R3 the error message is pretty normal for newer phones, since it wasn't designed with those in mind I'm guessing, My P20 Pro does it too.
markyap73 wrote:
Fri Sep 28, 2018 9:31 pm
Hi all,

I cannot connect my P20 Lite via USB on my 16 plate. Bluetooth is fine and I've got no problems on that. When I connect using the USB cable that came with the phone (with Android Auto running), the head unit doesn't even pick up a USB device (with Bluetooth off). I have tried different cables, adaptors and even on a different Corsa.... no luck. I've checked the settings on the head unit and all is good. Even tried my wife's Sony ZX and that linked with no problems, Google maps popped up on the display.

I've raised a help ticket with Vauxhall.... fingers crossed that they have a fix for this.
Regarding the R4 error, is the phone in the standard "Charge Only" mode for USB (I.E. the little pop-up you get when you plug it in) because iirc that blocks any form of data from being sent over the cable and only power is allowed. my guess would be try the different transfer modes it gives you, if it still doesn't work, then its probably to do with Huawei's USB interface and not the car.

if this is the case, im gonna hold off on the R4 Retrofit i was planning on doing and wait until i upgrade.
Ninja:
Image - A 2015 Corsa 1.2 LE in Carbon Flash


markyap73
Posts: 2
Joined: Fri Sep 28, 2018 9:12 pm

Re: Huawei P20 Android Auto

Post by markyap73 » Sat Oct 13, 2018 8:35 am

Regarding the R4 error, is the phone in the standard "Charge Only" mode for USB (I.E. the little pop-up you get when you plug it in) because iirc that blocks any form of data from being sent over the cable and only power is allowed. my guess would be try the different transfer modes it gives you, if it still doesn't work, then its probably to do with Huawei's USB interface and not the car.
When plugged in via USB (I've purchased numerous cables and tried the cable that came with the phone) I get no option. I've manually changed this in Developers mode but still no luck.... Still cannot see the phone on the head unit.

I'm hoping that Vauxhall will back to me but I'm not holding my breath.

If I hear anything, I'll post the results up.
😁


User avatar
Cabooshy
Posts: 12
Joined: Mon Jul 30, 2018 3:59 pm
Location: Fleet, GB
Contact:

Re: Huawei P20 Android Auto

Post by Cabooshy » Sat Oct 13, 2018 9:26 pm

markyap73 wrote:
Sat Oct 13, 2018 8:35 am
When plugged in via USB (I've purchased numerous cables and tried the cable that came with the phone) I get no option. I've manually changed this in Developers mode but still no luck.... Still cannot see the phone on the head unit.

I'm hoping that Vauxhall will back to me but I'm not holding my breath.

If I hear anything, I'll post the results up.
😁
Please do mate!
Ninja:
Image - A 2015 Corsa 1.2 LE in Carbon Flash


Post Reply

Return to “Main Corsa E chat”