WIPER BLADES FAULTY AGAIN & AGAIN

Faults and Technical chat for the Corsa E
Post Reply
User avatar
jaysen
Posts: 73
Joined: Thu May 28, 2015 6:32 am
Location: SUNNY ROCHDALE

WIPER BLADES FAULTY AGAIN & AGAIN

Post by jaysen » Sat Oct 03, 2015 4:40 pm

purchased my 1.4T. LE middle of may. I have only done 2.400 miles. most of them have been dry miles. I have now had 2 lots of wiper blades replaced by VX because they have left lines on the screen mostly on the drivers side. around 6 lines which is not acceptable. I clean the car every week including the blades, VX cannot explain why this keeps continuing, I have a Skoda Octavia ( remapped lol ) which is fitted with cheap blades 2 years since and still clear the screen excellent. anyone else experiencing the same issue !!!
Panoramic Tilt & slide sunroof
Bi-xenon headlights


User avatar
LimeyUK
Posts: 1357
Joined: Wed May 20, 2015 2:20 pm

Re: WIPER BLADES FAULTY AGAIN & AGAIN

Post by LimeyUK » Sat Oct 03, 2015 5:22 pm

Maybe cleaning them is what is causing it.

It could be excess residue on both the window and the blades that leaves the lines.

Most likely cause is that your blades are too tightly pressed against the window.
Corsa E - Excite A/C with Black Alloys - 1.4 Turbo EcoFlex - Lime Green - 3 dr

Image


skyblue1969
Posts: 342
Joined: Sat May 30, 2015 12:36 pm
Location: Coventry

Re: WIPER BLADES FAULTY AGAIN & AGAIN

Post by skyblue1969 » Sat Oct 03, 2015 7:05 pm

I had problems with my blades well only drivers side so vx changed them and still no good so I bought some bosch aerotwin blades bent the arm a little and now there no problem but my blades were juddering not leaving lines BTW how's that gearbox problem
2015 Corsa E Limited Edition 1.4 Turbo Carbon Flash 3DR


Jarviser
Posts: 1665
Joined: Thu Jul 02, 2015 9:18 pm

Re: WIPER BLADES FAULTY AGAIN & AGAIN

Post by Jarviser » Sat Oct 03, 2015 7:22 pm

jaysen wrote:purchased my 1.4T. LE middle of may. I have only done 2.400 miles. most of them have been dry miles. I have now had 2 lots of wiper blades replaced by VX because they have left lines on the screen mostly on the drivers side. around 6 lines which is not acceptable. I clean the car every week including the blades, VX cannot explain why this keeps continuing, I have a Skoda Octavia ( remapped lol ) which is fitted with cheap blades 2 years since and still clear the screen excellent. anyone else experiencing the same issue !!!
Do you use wax based shampoo or aqua wax type products? Keep it off the screen at all costs.

Edit: Skoda - is that the one with 16 valve radio??


User avatar
jaysen
Posts: 73
Joined: Thu May 28, 2015 6:32 am
Location: SUNNY ROCHDALE

Re: WIPER BLADES FAULTY AGAIN & AGAIN

Post by jaysen » Sun Oct 04, 2015 4:56 pm

skyblue1969 wrote:I had problems with my blades well only drivers side so vx changed them and still no good so I bought some bosch aerotwin blades bent the arm a little and now there no problem but my blades were juddering not leaving lines BTW how's that gearbox problem
my gearbox still having problems. very strange on Thursday. did around 60 miles mostly town work. not a fault with the box. done 20 miles yesterday 6 times 3rd gear problem. very frustrating !!!!
Panoramic Tilt & slide sunroof
Bi-xenon headlights


User avatar
jaysen
Posts: 73
Joined: Thu May 28, 2015 6:32 am
Location: SUNNY ROCHDALE

Re: WIPER BLADES FAULTY AGAIN & AGAIN

Post by jaysen » Sun Oct 11, 2015 4:51 pm

Finally having 2 new wiper arms fitted tomorrow under warranty plus 2 blades to be sure. still having issues with 3rd gear !!!
Panoramic Tilt & slide sunroof
Bi-xenon headlights


Jarviser
Posts: 1665
Joined: Thu Jul 02, 2015 9:18 pm

Re: WIPER BLADES FAULTY AGAIN & AGAIN

Post by Jarviser » Sun Oct 11, 2015 5:57 pm

I have not seen another car with such long passenger wiper arm. What is it, over 3 ft long to blade tip?


skyblue1969
Posts: 342
Joined: Sat May 30, 2015 12:36 pm
Location: Coventry

Re: WIPER BLADES FAULTY AGAIN & AGAIN

Post by skyblue1969 » Sun Oct 11, 2015 6:44 pm

I find the drivers side wiper arm to be the worst the passenger side is fine..mine started juddering again even though I've got expensive bosch ones fitted so I tried autoglym screen wash and that seems to clear the screen of contaminants pretty well giving better blade movement
2015 Corsa E Limited Edition 1.4 Turbo Carbon Flash 3DR


Jarviser
Posts: 1665
Joined: Thu Jul 02, 2015 9:18 pm

Re: WIPER BLADES FAULTY AGAIN & AGAIN

Post by Jarviser » Sun Oct 11, 2015 7:00 pm

I use that Autoglym at winter strength 10:1 all year round and it tends to stop judder for a while. Amazon usually do 5 litres for about £26


Icanfixanything
Posts: 2
Joined: Sat Nov 09, 2019 1:23 am

Re: WIPER BLADES FAULTY AGAIN & AGAIN

Post by Icanfixanything » Sat Nov 09, 2019 1:33 am

If you look at another thread on this forum you will probably find your problem. I fixed mine this morning. Check if there is scoring on the plastic windscreen trim. If so, this means that the linkage to the wiper arm has popped out of its socket and is too low causing the wayward manner in which the wiper moves and the catching of the mechanism. To fix, if you hold the bottom of the arm near the nut and sharply and firmly lift it up, it should "pop" back in the socket. If not, undo the nut, remove the wiper arm, replace the nut on the thread and use a claw hammer under the nut to pull it up. I did this and the wiper is perfect.


Post Reply

Return to “Faults & Technical”