Battery problems?

Faults and Technical chat for the Corsa E
Post Reply
Kencobean
Posts: 1
Joined: Sat Jan 19, 2019 4:44 pm

Battery problems?

Post by Kencobean » Sat Jan 19, 2019 4:50 pm

Hi all, any suggestions for this?

Thursday morning my car struggled to start. Put it down to cold temperatures. After leaving work later that day it did it again. Later on in the evening the same again. Once it eventually got going, I turned the engine off, then back on and started ok. Friday morning I called Green Flag our as did the same again. I was told my battery was running at 10% efficiency and I needed a new battery. I bought one myself and had a friend fit it. Late yesterday evening I started the car and it did the same again. Ran it for 40 minutes ish, engine off and then back on and it did the same again. Any suggestions? A friend has said maybe the alternator. Surely Green Flag should have picked that up?


Rickardo
Posts: 228
Joined: Thu Jan 26, 2017 1:23 pm

Re: Battery problems?

Post by Rickardo » Sun Jan 20, 2019 10:15 am

Didn't they test the alternator when diagnosing the problem


big-fish28
Posts: 36
Joined: Thu May 10, 2018 10:36 am

Re: Battery problems?

Post by big-fish28 » Wed Feb 06, 2019 3:09 pm

Out of curiosity, do you have a start-stop battery in your car? Would like to see how this panned out for you and know if you got to the bottom of this.

Fingers crossed the same doesn't happen to me - this cold weather is a nightmare!

All the best.


Post Reply

Return to “Faults & Technical”