P0121 system to lean (Bank 1)

Faults and Technical chat for the Corsa E
Post Reply
H.sahota99
Posts: 22
Joined: Wed Jul 24, 2019 1:30 pm

P0121 system to lean (Bank 1)

Post by H.sahota99 » Thu Nov 28, 2019 6:26 pm

My Eml came on whilst skowly moving in traffic. I cleared the code but it came back again.

Any advice

Thank you

H.sahota99
Posts: 22
Joined: Wed Jul 24, 2019 1:30 pm

Re: P0121 system to lean (Bank 1)

Post by H.sahota99 » Sat Dec 07, 2019 9:44 am

Anyone?

Michaelh8241
Posts: 1
Joined: Mon May 04, 2020 8:26 pm

Re: P0121 system to lean (Bank 1)

Post by Michaelh8241 » Mon May 04, 2020 8:28 pm

Did you ever resolve this problem? Currently having this problem myself after replacing the coil pack to sort a misfire

H.sahota99
Posts: 22
Joined: Wed Jul 24, 2019 1:30 pm

Re: P0121 system to lean (Bank 1)

Post by H.sahota99 » Tue May 05, 2020 10:54 pm

Michaelh8241 wrote:
Mon May 04, 2020 8:28 pm
Did you ever resolve this problem? Currently having this problem myself after replacing the coil pack to sort a misfire
No, its a bit strange as it'll appear then if my car hasn't been driven over the weekend it may disappear and may not appear for weeks. At the moment it isn't on but car doesn't get driven really due to lockdown.

Read online people suggest cleaning the maf, checking for any lose connections in the air intake and ensuring no cuts in the pipes etc.

Car doesn't seen to perform any different did have a my mpg drop when it started happening going down to 37ish, but i suspect that was due to it being winter and me blasting the heating whilst sitting in lots of slow stop start traffic.

Rickardo
Posts: 356
Joined: Thu Jan 26, 2017 1:23 pm

Re: P0121 system to lean (Bank 1)

Post by Rickardo » Wed May 06, 2020 11:55 am

To be clear P0121 relates to Throttle Position Sensor

P0171 relates to the system being too lean which is what the OP is talking about.

It could be the MAP sensor is failing and needs replacing

Does the issue arise when accelerating hard or under load?

Post Reply